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Introduction
InstallAnywhere is the leading multiplatform development solution for software producers needing to 
deliver a professional and consistent installation experience for cross-platform desktop and server 
applications. From a single project file and build environment, InstallAnywhere enables developers to 
create reliable installations for the broadest range of current platforms including Windows, Linux, MAC 
OS X, Solaris, AIX, HP-UX and IBM iSeries. From a company who set the standard for installations with 
InstallShield; InstallAnywhere brings that experience and knowledge for multiplatform developers, which 
allows developers to create high-quality installations, reducing technical support costs and increasing 
customer satisfaction.

InstallAnywhere 2011 has more capabilities to support distributed install development and deployment.   
As software teams implement agile development practices, they need more flexible ways to author, build 
and package installations. InstallAnywhere 2011 contains multiple enhancements to address key issues 
related to distributed and component-based install development and deployment.

New Features
This section describes the new features in the following versions of InstallAnywhere:

• InstallAnywhere 2011 SP4

• InstallAnywhere 2011 SP3

• InstallAnywhere 2011 SP2

• InstallAnywhere 2011 SP1

• InstallAnywhere 2011
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InstallAnywhere 2011 SP4
InstallAnywhere 2011 SP4 includes the following enhancement:

• Support for Windows 8 / Windows 2012 Server

Support for Windows 8 / Windows 2012 Server

InstallAnywhere 2011 SP4 supports the Windows 8 (64-bit) and Windows Server 2012 (64-bit) operating 
systems. 

• You can run the InstallAnywhere 2011 SP4 authoring environment on Windows 8 desktop and 
Windows 2012 Server operating systems.

• Installers created with InstallAnywhere 2011 SP4, or existing installers that are rebuilt using 
InstallAnywhere 2011 SP4 , will run successfully on Windows 8 desktop and Windows 2012 Server 
operating systems.

InstallAnywhere 2011 SP3
InstallAnywhere 2011 SP3 includes the following enhancements:

• Software Tagging Support

• Default Locale Support

• File Encoding for Modify Text File Actions

• Download File Action

• Support for VM Packs With Nested JRE Folders

• Support for Comment Action Group

• Modified Behavior of Console Launchers

Software Tagging Support

InstallAnywhere 2011 SP3 includes ISO 19770-2 software tagging capability. ISO/IEC 19770-2 is an 
international standard for the creation of software identification tags. A software identification tag is a 
small, XML-based file that contains descriptive information about the software, such as the product 
name, product edition, product version, and publisher. Software asset management tools collect the 
data in the tags to provide accurate application identification for software that is installed in an 
enterprise.

You configure software tagging for a project on the Project > Software Tag subtask.
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Default Locale Support

When defining locale settings for a project, you can now specify the language to use if the target 
machine’s operating system uses a language that is not supported by the installer.

You select a default language from the Default Locale for Targets with Unsupported Languages 
list, which is found on the Locales subtab of the Build Configurations tab of the Build task. If the 
installer is started on a platform that uses an unsupported language, then the selected language will be 
used.

File Encoding for Modify Text File Actions

In Modify Text File actions, InstallAnywhere now provides the ability to perform file encoding. You 
specify the encoding type specific to the version of Java you are using. If the encoding type you enter in 
the File Encoding field is invalid or unsupported, or if you leave this field blank, then UTF-8 encoding 
will be attempted. If the installer fails to apply UTF-8, then system default encoding will be applied.

Download File Action

You can now use the Download File action to download a file during installation using FTP, HTTP, SFTP, 
or Anonymous FTP protocol. 

Support for VM Packs With Nested JRE Folders

In addition to supporting normal VM pack structure, InstallAnywhere 2011 SP3 now also supports VM 
packs which have nested JRE folders (such as jre/jre/bin).

Support for Comment Action Group

To prevent an action group (and all of the actions that it contains) from being bundled with the installer, 
InstallAnywhere 2011 SP3 now provides a Comment Action Group option on the Properties tab of 
the Action Group customizer. 

The Comment Action Group option gives you an easy way to retain the actions in an action group in 
your installation project but to not include them in the built installer. If, at some future time, you wish to 
include these actions in the installer, you can clear the selection of the Comment Action Group option. 

Modified Behavior of Console Launchers

In order to suppress the display of unnecessary console windows when an installer which is bundled 
with a console launcher is launched in GUI mode, we have modified the behavior of console launchers 
to behave differently depending upon how the installer was launched. A table which identifies how the 
console launcher will behave in each situation is provided in the InstallAnywhere help library.
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InstallAnywhere 2011 SP2
InstallAnywhere 2011 SP2 includes the following enhancements:

• Apple OS X Lion (10.7) Support

• Rollback-Enabled Restart of Windows

• Resolving Variables at Build Time

• Customizable Merge Module Progress Bar

• Project Automation API Code Samples

• Support for Specifying Encrypted System i (i5/OS) Logon Credentials Using the Ant Task

• System i (i5/OS) Program Action Now Available in the Pre-Install and Post-Install Tasks

Apple OS X Lion (10.7) Support

InstallAnywhere 2011 SP2 supports Apple OS X Lion (10.7):

• Authoring environment support—The InstallAnywhere 2011 SP2 authoring environment 
supports Apple OS X Lion (10.7). If you first install InstallAnywhere 2011 and then apply the SP2 
patch, InstallAnywhere will run on Apple OS X 10.7.

• Installer environment support—Installers with a Macintosh build target created using 
InstallAnywhere 2011 SP2 will run on Apple OS X Lion (10.7).

Rollback-Enabled Restart of Windows

To instruct a target Windows machine to restart after a rollback occurs during installation, you can now 
select the Restart Windows in case of Rollback option on the Project > Advanced > Rollback 
Settings task in the Advanced Designer. 

Note • The Restart Windows in case of Rollback checkbox is enabled only after you select the 

Enable Rollback checkbox.

If the Restart Windows in case of Rollback checkbox is selected, the machine will restart once the 
user clicks the Done button in the Install Complete panel.

Previously, even if an installer’s Post-Install task included a Restart Windows action, it would not 
execute if the installer was rolled back. 

Note • If the Restart Windows in case of Rollback checkbox is selected, the target Windows 

machine will restart whether or not a Restart Windows action is present in the Post-Install phase, with 

one exception. If a Restart Windows action is present and you assign to it a rule that would prompt the 

user to choose between Yes, restart or No, I will restart later, if the user selects No, the machine will 

not restart even if the Restart Windows in case of Rollback option is selected.
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Note • This customer enhancement request was tracked as issue IOA-000061965.

Resolving Variables at Build Time

In InstallAnywhere 2011 SP2, you can now use build time variables, which are variables that have their 
values set at build time.

Instead of using the $ symbol as the variable delimiter (which is used for standard variables, such as 
$var$), you instead use the @ symbol as the delimiter for build time variables, such as @var@.

There are several ways of configuring build time variables:

• Configuring Build Time Variables in the Advanced Designer

• Configuring Build Time Variables Using a Property File

• Defining Build Time Variables as Environmental Variables

Configuring Build Time Variables in the Advanced Designer 

You can configure build time variables on the Project > Variables task of the InstallAnywhere 
Advanced Designer. 

Task: To configure build time variables in the Advanced Designer:

1. Open the Project > Variables task.

2. Click the BuildTime Variables button. The BuildTime Variables dialog box opens. 

3. Click the Edit Variables button. The Edit BuildTime Variables dialog box opens. 

4. Click Add. A new, empty variable is added to the BuildTime Variable list. 

5. In the BuildTime Variable column, enter a name for the new variable, such as @Apple@.

6. In the Value column, enter a value for the variable.

7. Click OK. The BuildTime Variables dialog box closes.

Configuring Build Time Variables Using a Property File

You can also define build time variables in a property file and specify this property file during the 
command line build. This method enables you to update variables just before build by editing the 
property file. 

During a command line build, the property file is specified using -btv "filepath", such as:

build.exe "C:\Projects\My_Project.iap_xml" -btv "C:\Properties\mypropertyfile.properties"

If there is duplicate variable present in the both the property file and in the Advanced Designer, then the 
variable defined in the property file will be given precedence over the variable defined in the Advanced 
Designer.
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Defining Build Time Variables as Environmental Variables

You can also define environment variables and then use them as build time variables in the project.

To define build time variables as environmental variables, define the environmental variables using the 
tag prefix of IA_BTV_, such as IA_BTV_VariableName (or @IA_BTV_VariableName@). The InstallAnywhere 
Advanced Designer will recognize these variables and list them in the BuildTime Variables table 
(which is displayed by clicking the BuildTime Variables button on the Project > Variables task). This 
table will list just the variable name without the IA_BTV_ prefix.

Note • This customer enhancement request was tracked as issue IOC-000086999.

Customizable Merge Module Progress Bar

In InstallAnywhere 2011 SP2, you can now customize the progress bar of a Merge Module. A new 
option entitled Show progress dialog has been added to the Install tab of the Dynamic Merge 
Module customizer of the Organization > Modules task. 

You specify the way a Merge Module’s installation progress is displayed by selecting or not selecting the 
Show progress dialog option:

• Selected—An intermediate progress bar will be displayed while this Merge Module is being 
installed. 

• Not selected—The intermediate Merge Module progress bar is suppressed, and the progress of 
the Merge Module installation is integrated into the progress bar of the parent installer.

Note • This customer enhancement request was tracked as issue IOA-000028353.

Project Automation API Code Samples

InstallAnywhere 2011 SP2 includes new Project Automation API code samples that you can use to edit 
your project files programmatically in Java. These code samples are installed in the following directory:

[InstallAnywhere Installation Directory]\project-auto\samples\src\com\ia\projauto\samples

A readme.txt file is provided in the project-auto\samples directory that contains the following 
information:

• How to Use—Explains how to run these code samples using classpath settings.

• Sample Code Configuration—Explains how to run these code samples by making use of ANT 
scripts that compile and run the API code samples by using an automationbuild.properties file.
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The following Project API code samples are provided:

Support for Specifying Encrypted System i (i5/OS) Logon Credentials 
Using the Ant Task

In InstallAnywhere 2011 SP2, you can now specify encrypted System i (i5/OS) login credentials using 
the i5OSLogin parameter of the Ant task:

<buildinstaller IAProjectFile="Project_File" IALocation="IA_HOME" 
i5OSLogin="hostname_or_ip/userName/password">

After the project successfully builds, an *-masked i5OSLogin parameter (password portion) will print to 
the console. 

Table 2-1 • Project API Code Samples

Advanced Designer Task/Subtask Provided Sample Code

Installer UI InstallerUIConfig_Test

Install InstallTask_Test

Pre-Install PreInstallAction_Test

Post-Install PostInstallAction_Test

Project ProjectDescription_Test

Project > JVM Settings JavaSettings_Test

Project > Platforms > Mac OS X MacOSPlatform_Test

Project > Platforms > Windows WindowsPlatform_Test

Build > Build Configurations > Build Targets BuildConfig_Test

Build > Build Configurations > Tags Tags_Test

Project > Advanced > Maintenance Mode MaintenanceMode_Test

Project > Advanced > Instance Management InstanceManagement_Test

Project > Log Settings LogSettings_Test

Project > Advanced > Rollback Settings Rollback_Test

Project > Rules Rules_Test

Uninstall UninstallPhase_Test

Actions: Expand Archive (7-Zip), 
Expand Archive (TAR), Read/Modify XML File

ReadReplaceXMLandSevenZipandTar_Test
InstallAnywhere 2011 SP4 Release Notes IA-12SP4-RN00 (10 August 2012) 8



Note • In previous releases, you could specify System i (i5/OS) login credentials during a command line 

build by using the -i command line switch, but the credentials would then be displayed in the build 

output in clear text (they were not encrypted).

Note • This customer enhancement request was tracked as issue IOA-000063510.

System i (i5/OS) Program Action Now Available in the Pre-Install and 
Post-Install Tasks

In addition to being available in the Install task, the System i (i5/OS) Program action is now also 
available in the Pre-Install and Post-Install tasks.

Note • This customer enhancement request was tracked as issue IOC-000078667.
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InstallAnywhere 2011 SP1
InstallAnywhere 2011 SP1 includes the following minor enhancement:

• Ant Task Reference Changes

Ant Task Reference Changes

In InstallAnywhere 2011 SP1, you can specify supported locales using the Ant task. Use the following 
updated syntax when defining a <configuration> parameter within a <buildinstaller> parameter:

<buildinstaller 
IALocation="C:\Program Files\InstallAnywhere 2011 Enterprise" 
IAProjectFile="C:\Projects\myproject.iap_xml" 
additionalparameter=value 
> 
<configuration name="Configuration_Name" 
webenabled="true/false" 
weboptimize="true/false" 
webpagelanguage="en/ja" 
cdenabled="true/false" 
cdoptimize="true/false" 
mergeenabled="true/false" 
mergeoptimize="true/false" 
mergereadonly="true/false">

<locales>
<localeSuffix>en</localeSuffix>
<localeSuffix>de</localeSuffix>
<localeSuffix>ja</localeSuffix>

...

...
</locales>
<target platform="windows" 
outputDir="outputDir" 
buildWithVM="true/false" 
buildWithNoVM="true/false" 
bundledVM="path_to_file" />

<target platform="linux" 
outputDir="outputDir" 
buildWithVM="true/false" 
buildWithNoVM="true/false" 
bundledVM="path_to_file" />

...

...
</configuration>

</buildinstaller> 
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InstallAnywhere 2011
InstallAnywhere 2011 includes new features in the following categories:

• Merge Module Enhancements

• JVM Enhancements

• New Actions

• Complex Rule Expressions With Multiple Operator Support

• Logging Enhancements

• Variables Enhancements

• Installer Enhancements

Merge Module Enhancements

InstallAnywhere 2011 includes the following merge module enhancements:

• Common Uninstaller for Merge Modules

• Unified Progress Bar for Merge Modules

• External Resource Bundle Support for Merge Modules

Common Uninstaller for Merge Modules

With InstallAnywhere 2011, you can choose to implement a single uninstaller which can uninstall both 
your main project as well as your merge modules.

To specify this option for a dynamic merge module, select the Uninstall Merge Module when parent 
is uninstalled option on the Install tab of the Dynamic Merge Module customizer on the 
Organization > Modules subtask for the specific merge module. The point of uninstallation of merge 
modules can also be configured using the Uninstall Merge Modules uninstaller action in the 
Uninstall task.

You can also specify this option for an individual merge module by selecting the Uninstall Merge 
Module when parent is uninstalled option on the Install Merge Module action customizer in the 
Install task.

Unified Progress Bar for Merge Modules

In releases prior to InstallAnywhere 2011, when a merge module was being installed, only the message 
Installing Merge Module was displayed on the Install Progress panel, with no indication of progress. 
Because large merge modules take a longer time to install, the end user was not informed of which part 
of the merge module was currently getting installed. 

Starting with InstallAnywhere 2011, the installation progress of merge modules is merged into the main 
installer’s progress information. Therefore, the end user can see the installation progress of a merge 
module reflected in the main installer’s progress bar on the Install Progress panel.
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External Resource Bundle Support for Merge Modules

Starting with InstallAnywhere 2011, merge modules can access their own external resource bundles 
and are also able to access the external resource bundles of their parent installer during the installation 
and uninstallation phases. This is applicable to one-level nested merge modules and to multiple-merge 
modules which get installed with a single parent. 

JVM Enhancements

InstallAnywhere 2011 includes the following JVM enhancements:

• JVM Search Enhancements

• Consolidated JVM Settings on New JVM Settings Subtask

• VM Pack Creation Utility

JVM Search Enhancements

InstallAnywhere 2011 gives you finer control over the JVM that is selected by the installer launcher. You 
can either choose to go with the default search algorithm or define JVM specs through which you can 
control the search directories, Windows registry search, and also control the validation of the found VM.

• Specifying VM Search Instructions on Build Targets Subtab 

• Using JVM Spec Files

Specifying VM Search Instructions on Build Targets Subtab

You can now specify new VM Search Instructions for each build target on the Build Targets subtab 
of the Build Configurations tab of the Build task. When setting the VM search instructions, you 
specify whether or not the installer should search for a VM on the target system, and whether to use a 
bundled VM or to download a JVM in VM pack format from a URL you specify.

Figure 2-1: VM Search Instructions Area of Windows Build Target on Build Targets Subtab
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If you do not want to include a Java virtual machine with this build target, select the Without VM option. 
If you select this option, you also need to select one of the following options to specify how the installer 
will find the VM it will use:

• Search for VM; if not found exit—Select this option to instruct the installer to search the target 
machine for a VM. If one is not found, the installer will exit. 

• Search for VM; if not found, download from URL—Select this option to instruct the installer to 
search the target machine for a VM. If one is not found, the installer will download a VM from the 
URL specified in the text box. 

• Don’t search for VM; download from URL—Select this option to instruct the installer to always 
download a VM from the URL specified in the text box.

If you want to include a Java virtual machine with this build target, select the With VM option. If you 
select this option, you also need to select one of the following options to specify whether the installer 
should use the bundled VM if a VM is found on the target machine.

• Search for VM; if not found, use bundled VM—Select this option to instruct the installer to 
search the target machine for a VM. If one is not found, the installer will use the bundled VM.

• Don’t search for VM; use bundled VM—Select this option to instruct the installer to always use 
the bundled VM, even if a VM exists on the target machine.

• VM to Bundle with Installer—If you select the With VM option, select a bundled VM from this list.

Important • While you can obtain VM packs by downloading them from the Flexera Software Web site, 

these VM packs are provided for your convenience only and should not be referenced by your installation 

project. Therefore, if you select the Search for VM; if not found, download from URL or Don’t 

search for VM; download from URL options, do not specify a URL pointing to one of the VM packs 

on the www.flexerasoftware.com website. If you do, the build will fail. Instead, you should host the VM 

pack on your own file server or FTP server and specify the URL to that location. 

Using JVM Spec Files

If you instruct the installer to search for a VM, it will use the JVM search instruction files specified in the 
JVM Search Settings list on the Build Targets subtab. You can instruct the installer to use more than 
one JVM spec file at the same time by listing more than one file in the JVM Search Settings list.

InstallAnywhere provides a set of JVM spec files which target all the supported platforms that you can 
use or you can write one of your own.
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Consolidated JVM Settings on New JVM Settings Subtask

In InstallAnywhere 2011, all the JVM-related settings have been consolidated into a single, convenient 
subtask: Project > JVM Settings. Previously, these JVM-related settings were spread across the 
Project > Platforms, Project > Config, and Project > Java subtasks.

The Project > JVM Settings subtask includes JVM settings organized into three tabs: 

• General Settings—Use to modify the settings for the entire project, such as classpath settings for 
your project’s LaunchAnywhere applications.

• Installer Settings—Use to modify the settings for the installer launcher, such as defining a list of 
valid VMs for installers built from this project, setting the heap size for the VMs, setting optional 
installer arguments, deciding whether to install the bundled/downloaded Java VM, and defining 
classpath settings.

• Search Panel Settings—Use to specify criteria to use to find valid VMs for the application you are 
installing. 

VM Pack Creation Utility

In InstallAnywhere 2011, you can use the Create VM Pack dialog box, which is opened when you 
select Create VM Pack on the File menu, to create a VM pack for any platform. On the Create VM 
Pack dialog box, you specify the directory where the VM is installed, the directory where you want to 
store the new VM pack, the platform of the new VM pack, and a name for the VM pack.

You can also use the VM Pack utility as a standalone tool on a machine where InstallAnywhere is not 
installed. 

New Actions

InstallAnywhere 2011 includes three new actions: Expand Archive (7-zip), Expand Archive (TAR), and 
Read/Modify XML File.

Expand 7-Zip (LZMA) Archive

In InstallAnywhere 2011, you can use the Expand Archive (7-zip) action to expand a 7-zip or LZMA 
compressed archive file. You can now make use of LZMA compression to compress your files and use 
this new action to expand these archives in a fast and reliable way. The Expand Archive (7-zip) action 
is available in the Install phase.

Expand TAR Archive

In InstallAnywhere 2011, you can use the Expand Archive (TAR) action to expand a TAR archive file 
on the target system. This action has the advantage of preserving the permissions of all files that are 
part of the TAR archive.
InstallAnywhere 2011 SP4 Release Notes IA-12SP4-RN00 (10 August 2012) 14



Read/Modify XML File Action

You can use the Read/Modify XML File action to modify an existing XML file on the target system or an 
XML file that the installer deploys on the target system. You can specify whether to read a specific value, 
replace a specific value, or find an occurrence of a specific value. You can search by XML element, 
subelement, or attribute, and can specify a variable to store the value. To perform complex modifications 
of an XML file, you can use multiple Read/Modify XML File actions.

Complex Rule Expressions With Multiple Operator Support

In InstallAnywhere 2011, you can now write complex rule expressions using multiple logical operators 
and precedence operators.

When you add multiple rules to an item, each rule’s unique ID is listed in the Rule Expression field 
and, by default, the rules are joined by the AND operator. 

If you want to write complex rule expressions, you can edit the expression in the Rule Expression field 
to use multiple logical operators—such as AND (&&), OR (||), and NOT (!)—and precedence operators 
(parentheses) to express the relationship between two or more rules. To validate the rule, click the 
Validate Rule Expression button.

Logging Enhancements

InstallAnywhere 2011 includes the following enhancements to its logging functionality:

• Consolidated Log Settings in New Log Settings Subtask

• Maintenance Mode and Uninstall Phase Logs

• Append STDERR and STDOUT to Install/Uninstall Log

• Consolidated Logging for Parent and Merge Modules

Consolidated Log Settings in New Log Settings Subtask

In InstallAnywhere 2011, all of the logging-related settings have been consolidated into a single, 
convenient subtask: Project > Log Settings. 

On the Log Settings subtask, you can enable logging during installation and also during the 
Maintenance Mode options (Uninstall, Add Features, Repair Installation, Remove Features), and 
can choose to append the stderr and stdout output to the install/uninstall logs.

Maintenance Mode and Uninstall Phase Logs

In InstallAnywhere 2011, the logging feature has been extended to the Uninstall and Maintenance 
Mode phases (Install, Add, Repair, Remove, and Uninstall). You can select the phases for which 
you want to enable logging and specify the path for each log file.
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Append STDERR and STDOUT to Install/Uninstall Log

In InstallAnywhere 2011, the stderr and stdout entries of any installation can be appended to the 
install/uninstall logs, which makes it easier to perform installation/uninstallation debugging. 

You can send installer debug output (stderr and stdout) to a console (or Console.app on Mac OS X) or 
store it in a file.

Consolidated Logging for Parent and Merge Modules

A merge module’s installation log can now be consolidated into the parent's installation log by selecting 
the Add merge module log to parent log option available in the merge module's customizer. For 
merge modules that are imported as a dynamic merge module from Organization > Merge Modules 
subtask, then this setting is available in the Install section of the customizer.

Variables Enhancements

InstallAnywhere 2011 provides several enhancements that make it easier to use and manage variables:

• Consolidated Variables Settings in New Variables Subtask

• Selecting Variables from a List

• Search and Replace for InstallAnywhere Variables

• Increased Number of User Magic Folders

• Avoid Substitution of Unknown Variables for Select Actions

• Choose Install Set Variables Now Recorded in Response Files

• Clarification on the Propagation of Variables from Merge Module to Parent Installer

Consolidated Variables Settings in New Variables Subtask

To enable you to manage variables more effectively, a new Project > Variables subtask is introduced, 
which you can use to advertise variables for merge modules, list variables to encrypt in or exclude from 
the response files, and set security options. 

The Project > Variables subtask also includes a scrollable list of all variables defined in the installation 
project. Each listed variable includes a Substitute Recursively option, enabling you to specify that 
you do not want the variable to be substituted at runtime. In cases where you expect that the variable 
could contain multiple $ characters—such as in a user-defined password—you would clear the 
selection of the Substitute Recursively option for a variable. 

Selecting Variables from a List

In InstallAnywhere 2011, instead of having to manually type in the name of variables in text boxes or text 
areas in your installation project, you can open the Choose Variable dialog box and select a variable 
from a list. 

While you are editing the contents of a text box or a text area, you can open the Choose Variable 
dialog box by pressing Alt + V. The Choose Variable dialog box lists all of the variables available in 
your project, grouped by category, with embedded help for the selected variable. Whenever you add a 
new variable to your installation project, the Choose Variable dialog box is refreshed to include it. 
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Search and Replace for InstallAnywhere Variables

In InstallAnywhere 2011, you can search a project to locate all references to a specific variable. You can 
choose to search for a variable in any of the installation tasks/phases (Pre-Install, Install, Post-Install, 
Pre-Uninstall, Uninstall, Post-Uninstall) and can choose to search Features and/or Components. You 
can also perform global replacements of variables. 

You can search for an exact match of a variable or for a partial text string in a variable. You also have an 
Ignore Case option.

To perform a variable search, select Search on the File menu or press Ctrl + F. Search results are 
displayed on the Search Results dialog box.

Increased Number of User Magic Folders

InstallAnywhere 2011 has increased the number of user Magic Folders from 10 to 25.

Avoid Substitution of Unknown Variables for Select Actions

With InstallAnywhere 2011, you can avoid the substitution of unknown variables for the select actions 
using the Do not substitute unknown variables option in the customizer of the action. The select 
actions include:

• Execute Command Action

• Execute Target File

• Execute Script / Batch File

• Set InstallAnywhere Variable (Single) Action

• Set InstallAnywhere Variable (Multiple) Action

If your installation project includes a nested variable which could possibly contain multiple $ characters 
(such as a password), this could result in the creation of an unknown variable. Therefore, select the Do 
not substitute unknown variables option to instruct InstallAnywhere to only resolve InstallAnywhere 
variables which are listed in the project under Project > Variables (the known variables).

Choose Install Set Variables Now Recorded in Response Files

In InstallAnywhere 2011, the Choose Install Set panel/console variables are now recorded in 
response files. Here is an example:

#Choose Product Features
#----------------------
CHOSEN_FEATURE_LIST=Application,Help
CHOSEN_INSTALL_FEATURE_LIST=Application,Help
CHOSEN_INSTALL_SET=Typical
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Clarification on the Propagation of Variables from Merge Module to Parent Installer

Variables usually do not propagate from the merge module to the parent automatically. For this to occur, 
the variables have to be advertised in the respective phases of installation. 

In general, $INSTALL_SUCCESS$ and $RESTART_NEEDED$ are two status variables which are used in the 
Install Complete panel. 

• $INSTALL_SUCCESS$—The $INSTALL_SUCCESS$ variable cannot be set externally because it is a 
read-only variable, and therefore it cannot be advertised. But InstallAnywhere supports the 
automatic propagation of this variable from the Pre-Install phase to the Post-Install phase (but not 
from the Install phase to the Post-Install phase) for a Dynamic Merge Module. 

• $RESTART_NEEDED$—The $RESTART_NEEDED$ variable has to be advertised in the Post-Install 
phase in order for it to be propagated from the merge module to the parent.

Installer Enhancements

InstallAnywhere 2011 provides the following enhancements to installer design and functionality:

• Option to Disable Cancellation of Installation

• Option to Change Installer and LaunchAnywhere Icons (Windows)

• Option to Specify .ico Files for Icons

• Signed JARs Support

• Prevent Multiple Launches of Installer/Uninstaller

• Disk-Space Checking and Related Display Enhancements

• Change Version at Build Time Using the productVersion Parameter in build.exe Command Line

• Billboard Timers

Option to Disable Cancellation of Installation

In InstallAnywhere 2011, you can select the Disable cancel button when install is in progress 
option on the Project > Info subtask to prevent end users from being able to cancel an installation 
using the Cancel button (or the close [X] button). Disabling the Cancel button during installation helps 
to avoid unfinished installations.

Option to Change Installer and LaunchAnywhere Icons (Windows)

In InstallAnywhere 2011, you can specify a custom icon to be displayed for the Installer or the 
LaunchAnywhere:

• Installer—The installer icon can be specified on the Installer Icon tab of the Installer UI > Look 
& Feel subtask. 

• LaunchAnywhere—The LaunchAnywhere icon can be specified in the customizer of the 
LaunchAnywhere.

Note • This feature is available for Windows only.
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Option to Specify .ico Files for Icons

In previous versions of InstallAnywhere, you could only specify a 16x16 or 32x32 .gif file as an icon. 
These .gif files were converted to .ico files internally, resulting in a significant reduction in quality. In 
InstallAnywhere 2011, this issue has been addressed. You can now specify an .ico file for an icon.

• Installer—On the Installer Icon tab of the Installer UI > Look & Feel subtask, you can specify 
a custom Windows icon file (.ico) to be used for the installer.

• LaunchAnywhere—On the Choose Icon dialog box, which is opened from a LaunchAnywhere 
customizer, you can also select an .ico file.

Note • You can specify an icon (.ico) file for the installer on Windows platforms only.

Signed JARs Support

InstallAnywhere now supports adding signed JARs as dependencies to Custom Code Actions, Custom 
Code Panels, Custom Code Consoles, and Custom Rules. Also, a JAR or ZIP file that contains custom 
code can now be signed.

In previous versions of InstallAnywhere, although you could build a project that contained signed JARs, 
the installer that was generated would not launch. InstallAnywhere would extract all entries of the signed 
JAR, including the manifests, and would add them to the installer ZIP files (such as execute.zip). But 
when the installer ZIP files were added to the classpath of the installer, the installer would fail to launch 
because Java Security Exceptions would be thrown when initializing the JAR. 

Starting with InstallAnywhere 2011, in the case of a signed JAR, InstallAnywhere will not unpack the JAR 
and the JAR entry will be left intact inside the execute.zip file during build time. Therefore, during 
runtime, the signed JARs are extracted to temporary directories and are added to the InstallAnywhere 
classpath, making them ready to be consumed for the custom codes or any relevant actions requiring 
the contents of this signed JAR. 

Prevent Multiple Launches of Installer/Uninstaller

InstallAnywhere 2011 enables you to prevent end users from being permitted to launch multiple 
simultaneous instances of the same installer or uninstaller (as identified by having the same Product ID). 
This can be specified using the Prevent multiple launches of an installer at a given time option on 
the Project > Info subtask.

Note • Invoking multiple simultaneous instances of the installer or uninstaller could corrupt the 

InstallAnywhere registry.

Disk-Space Checking and Related Display Enhancements

In InstallAnywhere 2011, you can create an installer that performs a disk space check at various points 
in the installation life cycle, and you can customize how that disk space is displayed.

To display disk space on the on the Pre-Installation Summary panel of the installer, select the Disk 
Space Information in setting on the customizer of the Pre-Install Summary panel, and select the 
magnitude you wish to use (Bytes, KiloBytes, MegaBytes, or GigaBytes) from the list.
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If you want to use more than one magnitude to display disk space information (such as to displaying 
Free Disk Space in GBs while showing Required Disk Space in MBs), you can use the following 
variables.

• Free Disk Space

$FREE_DISK_SPACE_BYTES$
$FREE_DISK_SPACE_KILOBYTES$
$FREE_DISK_SPACE_MEGABYTES$
$FREE_DISK_SPACE_GIGABYTES$

• Required Disk Space

$REQUIRED_DISK_SPACE_BYTES$
$REQUIRED_DISK_SPACE_KILOBYTES$
$REQUIRED_DISK_SPACE_MEGABYTES$
$REQUIRED_DISK_SPACE_GIGABYTES$

Change Version at Build Time Using the productVersion Parameter in build.exe Command Line

In InstallAnywhere 2011, you can use the productVersion parameter in the command line of build.exe 
to change the version of an InstallAnywhere project at build time. The following example changes the 
version to 2.1.3.24:

build.exe MyProduct.iap_xml productVersion=2.1.3.24

Note • Versions are conventionally represented in the following format: 

[Major].[Minor].[Revision].[Subrevision], such as: 2.1.3.24. 

Billboard Timers

In InstallAnywhere 2011, you now have more control over how much time billboards will be shown while 
the installation is in progress. 

When multiple billboards are specified, you can control how much time each billboard will be displayed 
while the installation is in progress by using the Display billboards for every nn seconds option on 
the Installer UI > Billboards subtask. The default time for a billboard to be displayed is 0.5 seconds. 
To change this time period, select the Display billboards for every nn seconds option and enter a 
number in the seconds box.
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Revised Licensing Procedure and 
Requirements for InstallAnywhere 2011

The procedure for setting up InstallAnywhere licensing has been revised. In earlier versions of 
InstallAnywhere, users with node-locked licenses registered their product by entering a serial number, 
while users with concurrent licenses used a Flexera Software-generated license file. In InstallAnywhere 
2011, both license models (traditional node-locked licenses and concurrent licenses) require a 
license file that is generated through a new Web site: the Flexera Software Product and License 
Center. 

• Node-locked licenses—With this license model, the product license is tied to a specific user and 
machine. This model is the traditional option and the one that is most often purchased. The license 
file is based on the host ID (the Ethernet/MAC address of the network interface card) for the 
machine on which InstallAnywhere is installed.

• Concurrent licenses—This model enables sharing or floating of InstallAnywhere product licenses 
among multiple users. With this model, you set up a licensing server in your environment, and 
install InstallAnywhere on as many machines as needed. The InstallAnywhere license is tied to the 
specific licensing server, and each machine checks out a license from the server when a user 
launches InstallAnywhere. The licensing server manages how many instances of InstallAnywhere 
can be run simultaneously based on the terms of the concurrent license that is purchased. For this 
model, the license file is based on the host ID of the licensing server.

Use the Flexera Software Product and License Center (https://flexerasoftware.subscribenet.com/) to 
generate and download the node-locked or concurrent license files that you have purchased and to 
view the license generation history. To learn how to use this site and set up the licensing for either 
licensing model, see the licensing instructions at:

http://www.flexerasoftware.com/instructions/product-license.htm

Note that if you have not purchased a license for InstallAnywhere, you can install it and use it for a 
limited number of days without setting up the licensing. The new licensing wizard that InstallAnywhere 
displays whenever you launch InstallAnywhere in evaluation mode shows you how many days are left in 
the evaluation period. If you do not set up the licensing within the evaluation period, InstallAnywhere 
stops working when the evaluation period ends. You can set up licensing at any time before or after the 
evaluation period ends.

Simultaneous Build Restriction
When building an InstallAnywhere project using the command line builder utility with a “build-only” 
node-locked license, you are permitted up to five simultaneous builds. Each time a build is started, a 
“token” is acquired, which is released once the build is finished. 

If you attempt to perform more than five simultaneous builds, you will see the following error message:

Simultaneous Build Manager: Error !!!
Reason=Exceeded Maximum Allowed Simultaneous builds for your license. 
Remedy=Please try building after one of your existing build processes complete. 
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Important • If you cancel a build by pressing Ctrl+C, that token will not be immediately released; it will 

be locked out for 12 hours, after which it will automatically be released. Therefore, if you cancel multiple 

builds using Ctrl+C, you may encounter this Simultaneous Build Manager error even though five 

simultaneous builds are not currently running. 

Resolved Issues
This section describes the resolved issues in the following versions of InstallAnywhere:

• InstallAnywhere 2011 SP4

• InstallAnywhere 2011 SP3

• InstallAnywhere 2011 SP2

• InstallAnywhere 2011 SP1

• InstallAnywhere 2011

InstallAnywhere 2011 SP4
This section describes the customer issues that were resolved in InstallAnywhere 2011 SP4:

Issue Description

IOA-000063596 When browsing to a directory with certain Chinese characters on Windows 
using the Choose Install Folder panel, characters are being displaying as ? 
and the installation cannot proceed.

IOA-000053505 When a product is installed on Windows Vista to a path which includes 
Unicode characters, the installer is unable to write a path to the Registry.

IOA-000065438 Installing on a Linux PPC 64 operating system fails, and displays the following 
message: IllegalStateException: Message digest cannot be cloned.

IOA-000066501 On a Japanese system, the text on a Get User Input - Advanced panel 
appears to be continuously reformatting, and the scroll bar flashes 
continuously.

IOA-000068361
IOA-000068462

Text messages are being clipped on the Display Message panel of installers, 
and on the Please Wait panel of the InstallAnywhere installer.

IOA-000068611 When specifying that you want to display disk space information in Gigabytes 
on the Pre-Install Summary panel, the Gigabytes are displayed in whole 
numbers.

IOA-000069534 The Choose Locale panel no longer automatically selects pt_BR or zh_CN 
when launched on a machine set to that locale.
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IOA-000069329 When the path of the installer is too long, it gets truncated on the Not Enough 
Disk Space panel.

IOA-000069646 The build time variable for product name is not resolved on non-English 
locales.

IOC-000080085 On a reinstall, every file that is installed is written again to the local 
.com.zerog.registry.xml file. After numerous reinstalls, the 
.com.zerog.registry.xml file can become so large that it causes an 
OutOfMemoryError and the install fails.

IOA-000070253 In the progress bar, InstallAnywhere displays the name of a plugin action that 
has already executed instead of the one which is going to be executed.

IOA-000072052 The environment variable fails to display after the installation is complete.

IOA-000071069 Uninstall hangs when attempting to uninstall a Set System Environment 
Variable action.

IOA-000064629 While cancelling the installation process in the Pre-Install phase, the log file 
is always generated on the desktop.

IOA-000066678 Unable to load project and save project through Project Automation 
Framework as non-root user on Linux.

IOA-000071966 Running installer in silent mode with -f switch without a value throws 
ArrayIndexOutOfBoundsException.

IOA-000069778 Build fails when DISPLAY is set to an empty value and the project contains a 
Get User Input Panel - Advanced.

IOA-000057509 Custom code action in Pre-Install task that uses 
ProductRegistryService.getNewestProduct(sc) causes 
com.zerog.registry.xml to be created when cancelled in Pre-Install.

IOA-000056103 External resource bundles are not built into the installer if the project is created 
on Windows and built on Linux.

IOC-000079130 The Pre-Install Summary panel shows the wrong information when the 
amount of free disk space available is around 21 TB.

IOA-000065589 The Installer Exit Code is set to zero (0) when the installer has rolled back due 
to a fatal exception.

IOA-000072612 When DISPLAY is set to an incorrect value and the installer is run in silent 
mode, a NoClassDefFoundError error is thrown and the temp directory is not 
cleaned up.

IOA-000073241 Installation crashes on Windows 2012 Server when the installer is built with a 
console launcher.

Issue Description
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InstallAnywhere 2011 SP3
This section describes the customer issues that were resolved in InstallAnywhere 2011 SP3:

IOA-000072869 The value of an Environment variable action is not set properly on Windows 
2012 Server and Windows 8 preview machines.

Issue Description

BZ-17093 Show Message dialog should be application modal (to the installer) rather than 
system modal.

IOA-000034756 Special characters like {:*?"<>} in the path of a Choose Alias, Link, Shortcut 
Folder (Panel and Console) action causes an error in the install log: 

Status: ERROR Additional Notes: ERROR - java.lang.
Exception: Failed to create directory:

IOA-000042447 Japanese file separator characters are not displayed on Summary Panel

IOA-000044286 Temp folder is created if the chosen install folder is other than the default drive.

IOA-000051361 Unable to use external resource bundle to handle custom strings in the 
Choose Language Console panel available in the installer user interface.

IOA-000052922 Get User Input panel throws an exception when running in silent mode.

IOA-000053488 Magic folder still being created even if a Check Platform rule should prevent 
this from happening.

IOA-000053591 Unable to locate a .war file by resource manager on interface when loading 
the projects.

IOA-000058096 Line wrap occurs in the middle of sentence in the Korean locale and in the 
Spanish locale on console mode.

IOA-000058552 Request that an "encoding" property for Modify Text File actions is provided.

IOA-000059031 Action groups in Pre-/Post Install sections are always opened expanded.

IOA-000061736 No message prompt is displayed during console mode when temporary space 
for extraction is not sufficient.

IOA-000062000 Labels with long strings in a Get User Input - Advanced panel display the last 5 
characters as an ellipse and is truncated. 

IOA-000062017 Closing brackets are not in the correct place (mirrored correctly) in the case of 
an Arabic installer.

Issue Description
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IOA-000062778 The text on the dialog box that opens when there is insufficient disk space in a 
temporary location is incorrect on the Japanese locale.

IOA-000063100 Calling Win32Service.getNTServiceKeyName with a service that does not exist 
causes the JVM to crash.

IOA-000064018 Uninstaller is not able to remove a new file added to the upgrade installer.

IOA-000064891 Installer bundled with IBM JVM for Linux does not launch when a “no JVM 
found” error is encountered.

IOA-000064923 Error message "strings: '/lib/libc.so.6': No such file" occurs on 
64-bit Linux during initialization.

IOA-000064924 Error message "Unzip: not found" is written when launching an installer on 
AIX and HPUX.

IOA-000064970 A particular Japanese translated message/string is unable to display in any 
panel in run time. 

IOA-000064998 IBM JVM bundled with Windows Installer gives the LaunchAnywhere Error 
"Windows error 3 occurred while loading the Java VM"

IOA-000065156 Expand Archive (TAR) action does not preserve original file permissions and 
symlinks.

IOA-000065296 Usually for non-English languages, the default translation is displayed on 
panels, but for some panels, referencing $L variable causes the comment line 
of the local locale file to display.

IOA-000065311 Not all features are recorded in the local InstallAnywhere registry file.

IOA-000065374 Labels of subcomponents of choice group on Advanced Get User Input Panel 
should be made localizable.

IOA-000065425 Request for enhancement to provide Comment Group action so that customer 
can comment out a bunch of action groups together which the developer is 
not yet ready to delete.

IOA-000065431 If the payload is only associated to a particular configuration which is missing 
from resource folder, then the build should be succeeded for all other 
configurations even though they are not associated with that missing payload.

IOA-000065825 The character '0' appears on the Uninstallation Complete panel when running 
the installer in the German locale.

IOA-000065986 Unable to load any ISMP services when running installer with a 1.7 JVM.

IOA-000066011 System i Program action is not resolving build time variables in the Program 
Development Library and Target Release properties consistently.

Issue Description
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IOA-000066012 Request that the System i Program Action be made available in both the Pre- 
and Post-Uninstall sequences.

IOA-000066026 Component versions are not being updated in the Global Registry when 
installing a newer version component to the same location as an older version.

IOA-000066047 Issues with Custom Code Action/Panels verifying the specified class is 
contained in the action's JAR file when the class name contains a build time 
variable.

IOA-000066061 Build time check for existence of class referenced in Execute Custom Code 
Action and Panel is failing.

IOA-000066113 Build Time Variable not resolved in Project > Info > Installer Name field.

IOA-000066234 Unable to generate a response file unless the file already exists when built with 
InstallAnywhere 2009 SP1.

IOA-000066280 InstallAnywhere variables and modifications to Panels should be propagated 
to all locale custom_xx files

IOA-000066584 Installer doesn't clean up the temp location when cancelling the installation at 
the splash screen.

IOA-000066829 Instance management error occurs with installer built from InstallAnywhere 
2011 Japanese Edition project.

IOA-000066953 When selecting Maintenance Mode options on the Project > Advanced task, 
the user interface response time is slow.

IOA-000067019 Build time variables are not being resolved when the project is built with the 
command line builder.

IOA-000067127 Command line builds do not use the icon specified in the Change Installer 
Icon field on the Installer Icon tab of the Installer UI > Look & Feel 
subtask, but instead always use the last icon built from the interface.

IOA-000067155 Improper Japanese translation in Console User Interface mode strings.

IOA-000067815 Project with Install from Manifest action which is created in IDE running on 
Windows will not build on Linux.

IOC-000066521 User should be able to specify a default language when running on a system 
with an unsupported language.

IOC-000078404 Choose Directory controls, both on the Choose Install Folder Panel and the 
Get User Input Advanced Panel, are not mirrored right-to-left.

Issue Description
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InstallAnywhere 2011 SP2
This section describes the customer issues that were resolved in InstallAnywhere 2011 SP2:

IOC-000080219 Allow both console and non-console launchers to be built at the same time, or 
create a single synchronous console launcher which does not display the 
console when running in GUI mode.

Issue Description

IOA-000034756 If special characters like {:*?"<>} are entered in the path of a Choose Alias, 
Link, Shortcut Folder (Panel and Console) action at runtime, installation 
completes, but an error is posted to the install log (Status: ERROR Additional 
Notes: ERROR - java.lang.Exception: Failed to create directory) and the 
shortcut/directory is not created. When a user enters any of these special 
characters, a warning message should appear indicating an invalid path. 

IOA-000046835 The installation log entry created as a result of a System i (i5/OS) Program 
action does not list the name of the program that was executed. This behavior 
is not consistent with the behavior of other System i (i5/OS) actions. 

IOA-000046836 When a System I (i5/OS) Command action is configured to use 
InstallAnywhere variables as arguments and is run multiple times, such as 
when used in a loop situation during the Pre-Install phase, it does not re-
evaluate the variables after the first time it is executed.

IOA-000049982 During runtime, the focus is set to the summary text area in the Pre-Install 
Summary panel instead of a button on the panel. If you press the tab key when 
the focus is on the Install button to navigate between the buttons in the panel, 
the focus is set to the summary text area (instead of another button on the 
panel). If you then press the Tab + Shift keys (which is supposed to move the 
focus in the reverse direction), the focus does return to the Install button, as 
expected.

IOA-000051967 An Execute Custom Code action which references a non-existent class 
should cause the build to fail and InstallAnywhere should display a message 
that explains the error. Instead, the build completes successfully, and at runtime 
the action is skipped and a note is added to the log file. 

IOA-000052022 For both the Panel: Custom Code action and the Execute Custom Code 
action, you enter the fully qualified class name to run in the Class field of the 
customizer. The Execute Custom Code action correctly resolves any 
InstallAnywhere variables that are entered in the Class field. However, the 
Panel: Custom Code action does not resolve any InstallAnywhere variables 
entered in the Class field, and therefore fails to display the panel when 
InstallAnywhere variables are used.

Issue Description
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IOA-000052056 iSeries (System i (i5/OS) actions do not log error information and, in some 
cases, report as SUCCESSFUL when the action failed.

IOA-000052448 When a variable is defined in all three installation sequences (Pre-Install, Install, 
and Post-Install) of an Install Merge Module action, the Merge Module does 
not advertise that variable correctly; the advertised variable only appears in the 
Pre-Install and Post-Install sequences. This occurs when setting both input 
variables and parent variables. 

IOA-000052538 When you attempt to load a project using the Project Automation API’s 
ProjectAutomation.loadProject() method, if the project contains a plug-in 
which has properties that were modified in the Advanced Designer interface, an 
exception is thrown and the project fails to load.

This also occurs when an AbortInstallAction plug-in is added in the 
Pre-Install phase when variables in the plug-in are added in the Advanced 
Designer interface. 

IOA-000056329 If a key is not found when using a Get Windows Registry Entry action during 
installation, InstallAnywhere is displaying a warning message 
(Win32Exception), even though the absence of a key is not an error. Get 
Windows Registry Entry actions are used to instruct the installer to perform a 
specific action based upon whether a key is found or not. If a key is not present, 
no error or warning message should be displayed; instead, the result should 
just be written to the log file as an informational message.

IOA-000057275 InstallAnywhere is unable to instantiate a 
com.zerog.ia.auto.project.actions.ExecuteAntScript from within the 
automation code. The class throws an exception and InstallAnywhere is unable 
to instantiate the Execute ANT Script action. The class should run with no 
exceptions.

IOA-000057880 consoleProxy.getVariable() returns the wrong value for a custom console 
plug-in action.

IOA-000058042 You cannot set the base location attribute on the directory chooser control 
using the automation API. The following error message is displayed and the 
default location in the directory chooser is set to the wrong directory:

The property 'magicFolderId' of 
'com.zerog.ia.installer.util.GUIGroupData' is not supported!

Using the getInstallFolder method of the Project class should return the User 
Install folder, not the System Drive Root.

Issue Description
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IOA-000059887 The Back, Open Folder, and New Folder buttons on the file chooser dialog 
box are not accessible via keyboard on the Linux operating system.

When running an installer on a Linux OS, the Choose Install Folder panel 
permits the user to choose a different install folder. If the user clicks the 
Choose button, a file chooser dialog box opens. If you press the Tab key, the 
focus moves from the Folder text area to the list of folders, and then to the 
Cancel and OK buttons, and then back to Folder text area—skipping the 
Back, Open Folder, and New Folder buttons.

IOA-000061896 If you rename a built installer executable that contains a space in its name to a 
name that contains an underscore “_” character (such as from 
Install Test.exe to Install_Test.exe), the installer will fail to launch and the 
following error message will be displayed:

Unable to execute the desired program.
Please get another copy of the installer and try again.

This error also occurs when you rename an installer executable that received a 
Compatibility Warning for being too long.

IOA-000063031 When using a static reference to GUIAccess from a CustomCodeAction in the 
Install sequence to disable the Cancel button, the Cancel button instead 
becomes enabled. This feature worked as expected in previous releases.

IOA-000063174 When opening a project that was migrated from InstallAnywhere 2010 SP1, the 
Project Automation interface throws ClassCastException.

IOA-000063403 Node-locked licensing does not work with the 64-bit Linux version of 
InstallAnywhere 2011 on RHEL 5.6. While the Registration Wizard correctly 
displays the Host ID, when you try to register the product with a node-locked 
license file, it fails. The same license works correctly for a 32-bit Linux version of 
InstallAnywhere 2011 on the same machine. 

IOA-000063410 Debug logs are printing the message of ChooseBundledVMs: Unable to locate 
the VM pack directory, which gives the user the wrong impression if he runs 
the installer in debug mode because the message gets printed whether the 
installer is built with VM or without VM.

IOA-000063804 If you have multiple Execute Script/Batch File actions in a sequence, the first 
action executes correctly, but then subsequent actions fail with a 
FileNotFoundException because the batch file is locked. 

IOA-000064051 When a dependency jar file is added to an Execute Custom Code or 
Execute Ant Script action, and the path to the jar file is defined in a source 
path variable, the Dependency view shows the absolute path to the jar file 
instead of the path defined in the source path variable. 

Issue Description
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IOA-000064147 If a user on the Install Complete panel of a Windows installer moves away 
from that panel (by clicking the Back button) and then returns to it, the 
Windows machine gets restarted even if the user selects the No, I will restart 
my system myself (Restart Later) option on the Install Complete panel.

IOA-000064186 In the Arabic locale, the icon used on installer panels to indicate upcoming 
steps is not mirrored; the icon points in the wrong direction. 

IOA-000064187 In the Arabic locale, when a long string requires the presence of a horizontal 
scroll bar, the scroll bar should be set to move from right to left rather than from 
left to right. 

IOA-000064306 If you install 64-bit version of InstallAnywhere 2011 on a 64-bit REHL 4.6 
machine, you are unable to register InstallAnywhere with a node-locked 
license.

IOA-000064341 Enabling SWVPD Registry Integration on AIX (by selecting the Enable SWVPD 
Registry Integration (AIX Only) option on the Project > Platforms > 
UNIX task) results in the following installation log error message:

Could not find matching component XMLElement.

The installation should complete successfully without errors.

IOA-000064437 A System i (i5/OS) Program action uses a Target Release of *CURRENT 
regardless of the Project setting. Even if you set the Target Release to 
'Other' V5R4M0 in the project, a target release of *CURRENT is used.

IOA-000064438 When building a project which contains a System i (i5/OS) Program action, 
the build creates a temporary file on the iSeries machine but does not delete 
this file when the build is complete.

IOA-000064770 On the Linux OS, if the Introduction panel of a Spanish-locale installer has a 
lengthy amount of text, that text is truncated.

IOA-000064805 As in IOA-000063136, the installer icon path that is set in Installer UI > Look 
& Feel > Icon Path is entered as an absolute path in the InstallAnywhere 
project file; it does not use source paths. When the value of this field is saved in 
the project file, InstallAnywhere must substitute parts of the path with the 
appropriate source path.

IOA-000064871 If you install a 64-bit version of InstallAnywhere 2011 on a Linux PPC64 (IBM 
Power) machine, when you try to activate it using a per desktop license serial 
number, an error message is displayed.

Node locked licensing, this copy of InstallAnywhere could not be 
registered using the node locked licensing file specified. Please 
check license file specified at <path> is a valid license for this 
node.

Issue Description
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IOA-000064893 On a Macintosh OS that has both a 32-bit and 64-bit Java version installed, the 
-d32 argument can used to run the Java in 32-bit mode. However, using the 
-d32 in Project > JVM Settings > Installer Settings > Optional Installer 
Arguments > Additional Arguments does not work; the -d32 argument is 
ignored and the installer still runs Java in 64-bit mode.

IOA-000065297 SpeedFolders, which should be built once, are being built multiple times (once 
for each build target). This significantly increases build time.

IOA-000065398 Attempting to change the icon for a shortcut which points to an installed file 
back to the default throws a ClassCastException error and you are unable to 
change the icon.

IOA-000065407 The project automation API is losing objects for different actions. The following 
issues were reported:

• Project Automation API is turning a licensed edition of a project to 
development unlicensed version.

• Project Automation API is losing objects, such as the 
VariablePropertyDataNonBiDi object in the Extract to File plug-in.

• The installLogUninstall variable is losing value from true to false.

• The following actions were lost:

com.zerog.ia.installer.db.RunSQLScriptAction

com.zerog.ia.installer.actions.InstallFile

(action relating to plug-in action)

com.zerog.ia.installer.actions.InstallDirectory

(action relating to plug-in action)

com.zerog.ia.installer.actions.EditVariableTable

• When multiple com.zerog.ia.installer.actions.CustomAction were 
used, all but one was lost.

IOA-000065544 While running an installer that was built using InstallAnywhere 2011 in console 
mode, attempting to display the command line installer help by using 
command line arguments causes the installer to fail and a fatal application error 
is displayed.

IOC-000069098 The first line of the Modify Text File action does not preserve formatting. If the 
text file contains spaces in front of the first word, they will all be removed.

IOC-000077787 The CustomCodeActionBuilder interface, which is provided to allow the 
installation developer to build resources into the installer, works for a 
customCodeAction but it does not work for a plug-in because the dependency is 
not built into the installer.

Issue Description
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InstallAnywhere 2011 SP1
This section describes the customer issues that were resolved in InstallAnywhere 2011 SP1:

IOC-000078406 The subcomponents of a Get User Input - Advanced panel are not recorded 
in the response file. If a Get User Input - Advanced panel includes a radio 
button and a text field, only the results variable of the radio button is recorded in 
the response file, but not the results variable of the text field.

IOC-000079298 The System i (i5/OS) Integrated File System (IFS) action does not log the 
destination IFS directory installed in the install log. 

IOC-000079299 The System i (i5/OS) Install File action does not log the installed file to the 
install log.

IOC-000079495 If all installer step labels are deleted from a project, and the project is built as a 
Merge Module, then the Merge Module cannot be imported as a Dynamic 
Merge Module. 

Issue Description

IOA-000063511 Customer requests a method to specify the supported locales using the Ant 
task that corresponds to the method used when using a Build Properties file. 
The Ant task currently does not support nested “locales” elements.

IOA-000063136 The installer icon path that is set in Installer UI > Look & Feel > Icon Path 
is entered as an absolute path; it does not use source paths. This field must 
substitute parts of the path with the appropriate source path.

IOA-000063057 Building a Windows installer on Linux causes a IOException when the build 
attempts to run a Windows executable file, Iconchng.exe, on Linux.

IOA-000051282 Actions contained in a nested install-time Merge Module are not executed and 
an exception is generated, which is written to the log output. This error was 
caused because the actions used in the nested Merge Module were not in the 
classpath of the installation. 

IOB-000058044 If a Merge Module contains a Set InstallAnywhere Variable action in the 
Pre-Install sequence (with the Evaluate any variables at assignment 
option selected) and that variable is advertised in the Install sequence under 
This Merge Module sets the following parent variables, backslashes will 
be removed from the value of the variable when it is displayed.

This behavior also occurs if the variable in the Merge Module is set using the 
InstallerProxy.setVariable method (because you are unable to deselect 
the Evaluate any variables at assignment option using this method).

Issue Description
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InstallAnywhere 2011
This section describes the customer issues that were resolved in InstallAnywhere 2011:

IOC-000076832 In projects that reference more than one Dynamic Merge Module, after you 
edit an advertised variable for a Dynamic Merge Module in the Dynamic Merge 
Module customizer, the focus shifts to the first Merge Module in the list. The 
focus should remain on the Merge Module being edited.

IOC-000076761 When a Get User Input panel is placed in the Pre-Install task of a Merge 
Module, and then the Merge Module is imported as a Dynamic Merge Module, 
the directory chooser input fields on the panel are inheriting the default values 
from the parent project, rather than the merge module. 

IOC-000063397 Customer requests the ability to add a listener to the Cancel button in a 
custom action during the Install task so that an event is fired as soon as the 
Cancel button is pressed. Because the RollbackHandler it is not called until 
after the currently running Install action completes (instead of as soon as the 
Cancel button is pressed), it does not work. 

IOA-000063137 A ZipException is written to the console when building a project which 
contains an Expand Archive action if the project was saved on Windows and 
then built on Linux.

IOA-000063469 Advertise variable for Single-Level Nested Merge Module displays its middle 
level variable being advertised when imported as a dynamic merge module in 
the outermost parent.

IOA-000062886 The LaunchAnywhere icon does not change when the .ico file is selected for 
the InstallAnywhere normal wizard.

Issue Description

IOA-000062262 Prevent the uninstaller from being launched more than once simultaneously.

IOA-000061766 InstallAnywhere variables which are configured to have their values excluded 
from the log—by selecting the Exclude Variable Entirely option on the 
Configure Variables dialog box—are being written to the log when used in 
an Execute Command Action.

IOA-000061185 The uninstaller for the new product does not get installed when using the 
Execute uninstaller action to call the uninstaller of previously installed product 
in the same USER_INSTALL_DIR location.

IOA-000060603 Command line builder is unable to use a relative path to the project file.

IOA-000060528 BuildOutputLocation property in InstallAnywhereAntTask is not respected 
when used in conjunction with the BuildWorkdirLocation property.

Issue Description
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IOA-000060497 In Silent mode, when the installer fails due to any rule, this information should 
be written to the installer log file.

IOA-000060373 InstallAnywhere Ant build fails with the exception NoClassDefFoundError: 
Common/Expand7zipListener on Windows 7 64-bit machine

IOA-000060357, 
IOA-000030958

There should be an option to customize the disk space units for displaying 
Available Disk Space and Required Disk Space in the pre-installation 
summary panel.

IOA-000060027 Get User Input Panel is not displayed correctly, when running in 
Maintenance Mode.

IOA-000059894 Copying rules from one InstallAnywhere action to another action does not 
copy the Rule operand.

IOC-000067628 Custom Panel is inaccessible using the GUI-Automation API when used in 
conjunction with the waitForPanel method.

IOA-000059263 If the ProductRegistryService is used to query for an instance of a product, 
and the USER_INSTALL_DIR already existed, then the resulting uninstaller is not 
able to remove the installed product. 

IOA-000058800 If the Enable RPM Registration (Linux) option is enabled, then the 
uninstaller does not clean up properly.

IOA-000058376 Install Complete panel displays the message associated with 
NONFATAL_ERROR even though the INSTALL_SUCCESS variable is set to 
FATAL_ERROR.

IOA-000058253 When the project has too many install sets, and the description of each of 
these install sets is huge, then the display of the install sets in the Choose 
Install Set panel is truncated.

IOA-000058108 Specifying JRE_1.6.0_10+ in the VM Search Settings will fail the JVM search 
even if JRE 1.6.0_21 is already installed in the target machine.

IOA-000057943 If a dynamic merge module contains custom code or plug-ins, then the parent 
installer which imports this dynamic merge module will fail to build. 
A java.io.FileNotFoundException is thrown at the build time.

IOA-000057914 When a complex hierarchy of features and subfeatures are present in the 
project, then the uninstallation does not remove all the files. This is due to the 
non-recording of the associated components in the Zero G Registry.

IOA-000057892 Rules are not evaluated on the Show Message Console Dialog action 
during Install phase.

Issue Description
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IOA-000057797 Custom Code actions should not write messages to the console when run in 
silent mode.

IOA-000057793 Generating a response file with the -r command line switch should not show a 
warning message The resource "/path/to/response.properties" is not 
accessible. Installer exiting... and exit the installation.

IOA-000057766 Even though the warning in the Not Enough Disk Space panel says You may 
choose Cancel to cancel this installation, the cancel button is disabled 
for this panel.

IOA-000057503 Error message has to be modified when the path of response file is not 
specified.

IOA-000057414 The uninstaller fails when the VM install folder is renamed.

IOA-000057291 Project Automation does not include support for the Compare 
InstallAnywhere Variables Numerically rule.

IOA-000057128 There should be an option to ensure that only the latest version of each 
component installed is stored in the Global Registry.

IOA-000057091 On selecting the Choose Product Features [Only] radio button in Choose 
Install Set panel, the CHOSEN_FEATURE_LIST, CHOSEN_INSTALL_FEATURE_LIST, 
CHOSEN_INSTALL_SET variables are not getting written into the response file

IOA-000056538 InstallAnywhere should have the ability to expand a 7-zip or LZMA Archive.

IOA-000055628 The IAAntTask should accept ant variables. The buildproperties.xml file 
should also recognize ant-style properties.

IOA-000055577 The uninstaller of the parent installer should also be able to uninstall 
associated merge modules.

IOA-000055515 Execute Script/Batch File and Execute Command actions should resolve 
the InstallAnywhere variables in the command when writing to the log file.

IOA-000055134 On Windows, if the user name has %% in the user name, and if the installer has 
a bundled VM and the bundled VM is not installed, then the installer fails to 
launch.

IOA-000054911 End users entering dollar sign characters ($) into input fields such as the Get 
User Input panel for the installer causes the installer to substitute the strings 
between two dollar signs ($). There should be a provision to avoid the same.

IOA-000053399 In Add and Remove Programs, a custom icon should be shown when 
installing a package instead of the default InstallAnywhere icon.

IOA-000052725 In some cases, the parent project file is corrupted because of the failure of the 
merge module build, leading to the hanging of InstallAnywhere interface.

Issue Description
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IOA-000051551 When a variable in a parent project is resolved that has been set from a merge 
module’s advertised variable which is never initialized, the variable resolves to 
the string <null> instead of an empty string.

IOA-000050960 Enhance the logging capabilities of merge modules so that all phases of the 
merge module (Pre-Install, Install, Post-Install) are able to be redirected to 
STDOUT and written to one file.

IOA-000043955 If the uninstaller uses the Launch Uninstaller action to run a sub-uninstaller 
and if the sub-uninstaller requires Mac Authentication, the sub-uninstaller is 
run in GUI mode, even if the Always run silently property is selected.

IOA-000042863 There should be an option to set a timer for the Billboard display.

IOC-000071056 There should be an option for adding additional jars/zips to the installer’s 
classpath.

IOA-000041200 Newly introduced advertised variables in dynamic merge module are reflected 
in the parent installer only after a rebuild.

IOC-000058664 Using a signed jar file for custom code or its dependencies causes an 
ExceptionInInitializeError and fails to launch the installer.

IOC-000058089 There should be an option to prevent multiple instances of an installer from 
running simultaneously.

IOA-000030959 Disk-space-related variables should be made available during Pre-Install.

IOC-000056810 Add a command line switch to allow the version number for a product to be set 
during build time. 

IOA-000029294 Add an option to generate an Uninstall log.

IOA-000028765 On Linux, adding a link using the Add File option in the interface installs the 
link’s target file during install time, not the link.

BZ-15719 Add an option to disable the Cancel button when installing files.

IOA-000060505 Nested merge module does not get installed in HPUX Itanium.

IOC-000079674 The File Chooser of a Get User Input - Advanced panel does not resolve 
an InstallAnywhere variable when it is put in a Merge Module.

Issue Description
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InstallAnywhere Licensing Procedures
Two different licensing models are available for InstallAnywhere:

• Node-locked licensing—The product license is tied to a specific user and machine. This model is 
the traditional option and the one that is most often purchased. See also Node-Locked Licensing 
Issues.

• Concurrent licensing—This model enables sharing or floating of InstallAnywhere licenses among 
multiple users. With this model, you set up a licensing server in your environment, and install 
InstallAnywhere on as many machines as needed. The InstallAnywhere license is tied to the specific 
licensing server, and machines check out a license from the server when you launch 
InstallAnywhere. The licensing server manages how many instances of InstallAnywhere can be run 
simultaneously based on the terms of the concurrent license that is purchased.

These licensing models and licensing-related procedures for InstallAnywhere are described in the 
Flexera Software Product Download and License Guide for InstallAnywhere, which can be downloaded 
from the Flexera Software Web site:

http://www.flexerasoftware.com/downloads/instructions/productlicensing/en/
InstallAnywhereProductLicensing.pdf

Node-Locked Licensing Issues

You may encounter the following issues when installing InstallAnywhere using a node-locked license:

• Registering InstallAnywhere 2011 on a 64-bit Linux machine—When attempting to license 
the 64-bit version of InstallAnywhere 2011 on a 64-bit Linux machine, after specifying the correct 
license file, the Licensing Wizard may display an error message stating that InstallAnywhere could 
not be registered. The issue is caused by how the native library necessary for node-locked 
licensing was compiled and differences between various Linux operating systems. For information 
on resolving this issue, see the Q214129: Unable to License 64-Bit Version of InstallAnywhere 2011 
Using a Node-Locked License File on 64-Bit Linux Operating Systems KB article at:

http://kb.flexerasoftware.com/selfservice/microsites/
search.do?cmd=displayKC&docType=kc&externalId=Q214129&sliceId=1&docTypeID=DT_ISSU
E_1_1&dialogID=121017293&stateId=0%200%20121015158

• Installing InstallAnywhere 2011 on Linux-based systems—When you install InstallAnywhere 
on a Linux system, the installation attempts to create a symbolic link to the default Linux loader 
(/lib/ld-linux.so.2) if a link with the same name is not already present. This attempt may be 
unsuccessful. For information on resolving this issue, see the Q209204: Installing InstallAnywhere 
2011 on Linux-Based Systems KB article at:

http://kb.flexerasoftware.com/selfservice/microsites/
search.do?cmd=displayKC&docType=kc&externalId=Q209204&sliceId=1&docTypeID=DT_INFO
_1_1&dialogID=121017293&stateId=0%200%20121015158
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System Requirements
InstallAnywhere 2011 SP4 has the following system requirements:

• For Systems Running InstallAnywhere (Authoring Environment)

• For Target Systems (Installer Environment)

• Supported Java Virtual Machines

For Systems Running InstallAnywhere (Authoring 
Environment)

InstallAnywhere 2011 SP4 has the following system requirements for systems running the 
InstallAnywhere authoring environment:

Item Description

RAM 128 MB free

Color Minimum of 8-bit color depth (256 colors)

Resolution Minimum 1024 x 768 resolution

Operating System InstallAnywhere runs on the latest versions of these operating systems, 
fully updated with the most recent patches and service packs:

Windows • Windows 8 (64-bit)

• Windows 7 (32-bit and 64-bit)

• Windows Vista

• Windows XP

• Windows 2000

• Windows Server 2012 (64-bit)

• Windows Server 2008 R2 (64-bit)

Macintosh Mac OS X 10.4, 10.5, 10.6 (with Java 1.6+), and 
10.7 (with Java 1.6+)
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Operating System

(Continued)

Linux • Red Hat Enterprise Linux 4 and 5 (32-bit and 
64-bit)

• Red Hat Enterprise Linux 6 (32-bit and 64-bit)

• SUSE Linux 9, 10 (32-bit x86)

• SUSE Linux 11.2, 11.3, 11.4 (32-bit and 64-bit)

• Linux PPC 64-bit (build time only) only on 
JRE 1.6

• Ubuntu 10.10 (32-bit and 64-bit)

• Fedora 14

Note • When you install InstallAnywhere on a Linux 
system, the installation attempts to create a symbolic link to 
the default Linux loader (/lib/ld-linux.so.2) if a link 
with the same name is not already present. The symbolic 
link is necessary for the host ID to be displayed on the Host 
ID dialog, and it is also necessary for successful node-
locked licensing. The link is present on systems that are 
Linux Standard Base (LSB) 3 compliant, but it may not be 
present on systems that are not LSB compliant. For more 
information, see Knowledge Base article Q209204.

Solaris Solaris 9, 10, and 11 (SPARC - Express Edition)

HP-UX HP-UX 11i (PA-RISC)

AIX AIX 5.2, 5.3, and 6.1 (Power/PowerPC)

Note • A Japanese-localized version of InstallAnywhere Enterprise Edition is 
available on the Windows platform only. Installers can be built from any platform for 
any other platform or language. Localizations for 31 languages are included with 
Enterprise Edition. Localizations for 9 languages are included with Standard Edition.

Item Description
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For Target Systems (Installer Environment)
The following are the system requirements for systems running InstallAnywhere 2011 SP4 installers:

Item Description

RAM 64 MB free

Color Minimum of 8-bit color depth (256 colors)

Resolution Minimum 640 x 480 screen resolution

Operating System Installers run on any version of these operating systems, as long as the 
operating system supports Java 1.4 or later (including JRE 7.0). 

Note • InstallAnywhere installers are not supported on beta or on early access releases 
unless explicitly mentioned.

Important • While InstallAnywhere 2011 and all of its service packs will continue to 
support Java Runtime Environment 1.4 (JRE 1.4), users are requested to consider 
moving to a later release of the JRE. In the next major release of InstallAnywhere, 
InstallAnywhere 2012, JRE 1.4 will no longer be supported.

Windows • Windows 8 (64-bit)

• Windows 7 (x86 and x64)

• Windows Vista (x86 and x64)

• Windows XP (x86, x64, Itanium 2, and AMD-64)

• Windows 2000 and NT (x86)

• Windows Server 2012 (64-bit)

• Windows Server 2008 (x86 and x64)

• Windows Server 2008 R2 (64-bit) 

• Windows Server 2003 (x86, x64, Itanium 2, and AMD-64)

Macintosh Mac OS X 10.2, 10.3, 10.4, 10.5, 10.6, and 10.7 (Lion)

Linux • Red Hat Enterprise Linux 4 and 5 (x86, Itanium 2, and 
AMD-64)

• Red Hat Enterprise Linux 6.2 (32-bit and 64-bit)

• SUSE Linux 9, 10, 11, 12.1 (32-bit and 64-bit)

• Linux on zSeries

• Linux PPC (64-bit)

• Ubuntu 9.10, 10.10, 11.4 , 11.10 (32-bit and 64-bit)

• Fedora 13, 14, and 15

Solaris • Solaris 9, 10 (x86 and AMD-64) and 11 (SPARC - Express 
Edition)

• Solaris 11 (x86)
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Supported Java Virtual Machines
InstallAnywhere 2011 SP4 supports the following Java virtual machines:

Note • While InstallAnywhere 2011 and all of its service packs will continue to support Java Runtime 

Environment 1.4 (JRE 1.4), users are requested to consider moving to a later release of the JRE. In the 

next major release of InstallAnywhere, InstallAnywhere 2012, JRE 1.4 will no longer be supported.

The InstallAnywhere installer installs Java 1.6 VM packs. Any Java virtual machine can be bundled with 
an installer ensuring that the target system meets the minimum requirements for both the installers and 
your applications. To download additional VM packs, go to http://www.flexerasoftware.com/
installanywhere/utilities and open the VM Packs tab.

Note • InstallAnywhere installers are not supported on beta or on early access releases of Java.

Known Issues
For a complete list of known issues, see Knowledge Base article Q212832.

HP-UX HP-UX 11i (Itanium 2 and PA-RISC)

AIX AIX 5.2, 5.3, 6.1, and 7.1 (Power/PowerPC)

IBM • i5/OS (OS/400) on System i - V5R3 and V5R4 (Enterprise 
Edition only)

• z/OS

Other • FreeBSD

• Other Linux and Unix operating systems (POSIX-
compliant shell required)

Manufacturer Versions

Sun 1.4.x, 1.5.x, 1.6.x

IBM 1.4.x, 1.5.x, 1.6.x, 1.7.x

Apple 1.4.x, 1.5.x, 1.6.x

HP 1.4.x, 1.5.x, 1.6.x

Oracle 1.7.x 

Item Description
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Sending Us Feedback
Your feedback is essential to helping us deliver features in InstallAnywhere that meets your needs. Many 
of the features for InstallAnywhere come directly from the feedback and suggestions that you, the 
InstallAnywhere developer community, have shared with our engineering and support teams. To provide 
feedback, see Product Feedback.
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